Overview
This article provides information on how to fix the Privacy Information for your iOS app submission when BiznessApps' automated process fails to do so.
Diagnosis
As a BiznessApps customer, you have received a message from our iOS Uploads Team requesting you to follow the instructions in this article to submit your app to Apple's review.
Solution
- Log in to App Store Connect.
- If you are added to multiple teams, pick the correct team from the top-right dropdown list.
- Click "My Apps".
- Click on the app in question.
- Select the desired App and go to the App Privacy tab.
- If there's no data, click Get Started:
- Fill the form as follows:
- Select Yes, we collect data from this app and hit Next.
- Select Product Interaction and hit Save.
- In the new screen, click Set Up Product Interaction:
- Select Analytics and hit Next.
- Select "No, product interaction data collected from this app is not linked to the user's identity" and hit Next three times in a row.
- Select "Yes, we use product interaction data for tracking purposes".
- In the final screen, hit Publish.
- Go back to the App Submission (first option in the left-side menu), hit Save and then Submit for Review.
If only one type is showing up under Usage Data, you need to click "Edit" right next to Product Interaction, as depicted below, and then follow steps 8 to 10.
Testing
Once you click "Submit for Review", you should be presented with the following screen, confirming that your app is now under review:
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