Overview
You may come across issues with users not receiving Push notifications on their Android devices. This article explains why this may occur and provides a resolution to this error.
Diagnosis
You will notice that Push Notifications do not appear on your Android device. It is most likely that this error occurs when "Floating Notification" or "Lock screen notification" is probably disabled.
New settings have been added for notifications with the release of Android v8.0 and these probably cause these Push Notifications issues.
Prerequisites
- Android v8.0 onwards
Solution
You have to follow the following procedure for each app you want notifications to appear. Then you need to check each channel one-by-one within that app whether everything is toggled on (i.e., enabled). Please note that some apps may have even more than ten channels.
1. On your Android device, navigate go to Settings > (Installed) Apps > the App you want notifications to show.
2. Click on the "Notification" button.
3. In there, there is a toggle "Show notifications" that you need to activate. It most likely is already enabled.
4. Below you can find the "Notification categories" officially known as "Notification channels".
5. For each channel, you have a button. You need to enter each channel.
6. Enable the toggles within the channel.
7. Repeat the last two steps for all channels.
Testing
You will start receiving notifications on your Android device.
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