Overview
You tried to publish your iOS app on the CSM side, but you were not able to proceed with all the steps as you couldn't get past the 'Checking account' phase. This article explains why this might happen and how you can work around it.
Diagnosis
During the iOS publication process on the CMS, you reached the iOS Submission Info Page which prompted you to enter your Apple username, password and Developer Name.
Having set them and clicked on the Next button you get a screen reading 'Checking account'.
After a while, you get redirected to the previous step (as per the 'iOS Submission Info' screenshot above) where again you need to enter your Apple username, password and Developer Name and this way you cannot finalize your iOS publishing procedure.
This is usually because there's a problem with your Apple Developer Account. This problem often lies in the App-Specific password which is either not set at all or not properly configured.
Prerequisites
- Access to Apple Developer Account
Solution
You need to generate an App-Specific password.
Follow the procedure outlined in the Using app-specific passwords KB article in the 'How to generate an app-specific password' Section.
It is worth mentioning here that the app-specific password is 16 characters long (4 tuples of 4 characters each separated with a hyphen sign).
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Note: If you do not see the option to generate app-specific passwords, you will need to enable two-factor authentication, which is different than two-step verification.
Testing
Once you create the app-specific password and your account is set up properly, the 'Checking account' phase will take you to the next screen where you will be asked the Two-factor-Authentication (2FA) 6-digit code or the Two-Step-Verification (2SV) 4-digit code, depending on which one you are using on your Apple Developer account.
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