Overview
You have set up your support email (the email account used to send the order confirmation email to app users) and the admin email (the email account where you receive a copy of the confirmation email sent to the app user), but neither the end-user gets an email nor you receive a copy of the confirmation email. This article explains why this might occur and what you can do to work around it.
Diagnosis
You have noticed that when an order is placed by an app user, the user doesn't get the order confirmation email and also you don't receive a copy of that order confirmation.
This usually happens when the receiver’s email client rejects an email as it does not appear to originate from the mail server that it claims to be (mainly when general domains like gmail or hotmail are chosen).
More specifically, the case is usually as follows:
1) You create account/feature that should send email from abc@somedomain.com
2) Biznessapps sends the mail with from:abc@somedomain.com via Mailgun
3) Receiver def@gmail.com receives an email from abc@somedomain.com
4) The receiving Gmail server sees that email originated from non an email server that doesn't match somedomain and discards the email because of impersonation.
Note: All BiznessApps emails are sent over Mailgun Service provider (ie used as Outbound Server) and are impersonated
Solution
- Unfortunately, there is no workaround for public domains, such as gmail.com and hotmail.com. The only thing you can do is to change the email address used for the app owner email and admin email to another email. This usually requires you move to a non-public domain where you can configure the settings (see below).
- Thus if you do move to a non-public domain and as such you own the domain and are able to configure the email server, please follow the steps below:
Add the domain you own and verify it by setting up the DNS records we provide below (known as SPF) at your DNS provider.
SPF: Sending server IP validation. Used by the majority of inbound mail servers.
Type | Value | Purpose |
TXT | “v=spf1 include:mailgun.org ~all” | SPF (Required) |
Testing
You will start receiving order confirmation emails both as an app user (and so will the actual app users) and a copy for these order confirmation emails.
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