Overview
You received an app rejection error related to Apple's 2.3 Guideline - Performance - Accurate Metadata. This article explains why your app might have got rejected and how you can work around it.
Diagnosis
You got the following message from Apple for your iOS app.
Guideline 2.3 - Performance - Accurate Metadata
We noticed that your app's location modal alert includes the following information, which is not relevant to the app's content and functionality
This is due to Apple's Guideline 2.3:
Customers should know what they’re getting when they download or buy your app, so make sure your app description, screenshots, and previews accurately reflect the app’s core experience and remember to keep them up-to-date with new versions.
This is usually because:
- Your app’s location permission modal alert references GPS running in the background, which is not relevant to the app's functionality.
- Apple is unable to locate some of the features described in your metadata.
Solution
Most of the times the above can be resolved by
- (if it a GPS related issue) Disabling the Walkthrough feature when publishing and re-enable when the app is published in the App Store.
- On your app's Dashboard, Navigate to Create -> Build -> Walkthrough -> Slide the button to the left under the Content->Screens
- Republish the app
- Wait for the app to be published on the App Store and when this is done, re-enable the Walkthrough feature, by sliding the button of the above picture to the right.
- On your app's Dashboard, Navigate to Create -> Build -> Walkthrough -> Slide the button to the left under the Content->Screens
- (if it is because they couldn't find the features described in your metadata) Ensuring that all your app features are related to the app name and purpose. Check the App Metadata KB article for more information. It may be worth checking the Apple's Rejection Due To Incomplete Information In Your App’s "What’s New" KB article, too.
Testing
You will have managed to publish your app successfully without receiving this error message.
Comments
1 comment
This is happening on Google as well, for reference tickets #2394049 and #2394136.
Please sign in to leave a comment.