Overview
When making payment using Stripe as a payment gateway, the error "There was a problem with your card" appears. This article explains why this error occurs and how you can resolve it by adding the correct API key.
Diagnosis
Upon making a payment using Stripe as a payment gateway you got the following error:
There was a problem with your card
This error usually when you are not using the production credentials/Live API keys.
Solution
1. Logon to your Stripe Dashboard and Navigate to Developers -> API Keys and locate under your live API keys, your secret key. Copy this key.
Note: You can check the following video for further information on Stripe Live API Keys. The beginning of the video shows how you can find your Live API secrete Key
2. Once you have copied the correct API key in step #1, Log on to the CMS platform.
a. Navigate to Create > Build
b. Locate the feature that requires the API (In this example, this is the Food Ordering Feature)
c. Go to Payments, and paste the API Secret Key
d. Click Save on the upper right-hand corner
Testing
You will be able to proceed with the payment and you won't receive the There was a problem with your card error.
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