Overview
You got a "User <emailaddress> is not assigned to any team" error upon publishing an iOS app. This article provides possible reasons why this issue may occur.
Diagnosis
When publishing or republishing an iOS app, you encountered the following error:
User <emailaddress> is not assigned to any team
This error is directly related to the Apple ID. This issue may occur due to the following reasons:
- The wrong Apple ID is used instead of the Account Holder's Apple ID.
- The Apple ID is not set up as a Developer Account.
Solution
-
- Log in to Apple Developer Application.
- Check if there are any messages on the home page. For example, "Enrollment is being processed."
Please note that that the confirmation of the account can take up to 48 hours. If the developer is outside of the USA, sometimes, it can take up to two weeks. - Check if any information is missing in the account and add it accordingly
For further details on the issue and possible troubleshooting, contact Apple Support.
Testing
You will not be getting the same error upon (re)publishing your app.
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