Overview
When an app is unpublished or not active, it will show a default message ("This app is no longer being maintained due to non-payment on behalf of the business.") upon launching. This article covers why this happens and the steps to change this message to meet your needs.
Diagnosis
When users launch the app, they see the message:
This app is no longer being maintained due to non-payment on behalf of the business.
This occurs when an app is unpublished or the account becomes inactive due to non-payment or cancellation.
Prerequisites
- Partner/Reseller Account
Solution
- Log in to the CMS portal and, under your account, click My Client's View.
- Click Translations.
- Click Mobile Apps.
- Select Common from the drop-down menu.
- In the search bar, type the text
maintain
and click the magnifying glass to search. - The current inactive message appears in the search results under the Original section. Type your new message in the field under the Translation section.
- Click Save.
The same message appears for all unpublished apps in your reseller account. Therefore, we suggest you make it as generic as possible and not specific just for one app. For instance:
Oh, no! This app has been canceled. We apologize for any inconvenience. Please contact the organization if you have any questions.
Note: BiznessApps does not have a maintenance mode to temporarily take apps offline. The only way is to Unpublish the app. If you need to limit functionality on an app, features can be deactivated.
Note: Apps published prior to December 2018 may be on old source code; these apps may still display the default message since the message was previously hardcoded. To change the message for these apps, they need to be republished on the current source code first.
Testing
Once you try to launch the inactive app, you will get a message containing the text you configured above.
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