Overview
You need to add your phone number as a trusted phone number for your client's Apple ID to be able to receive the Two-Factor Authentication (2FA) code on your phone so you can submit the iOS app on behalf of your client. This article describes the process of adding a reseller's phone number as a trusted phone number.
Diagnosis
As a reseller/partner, you need an alternative option to avoid having the client on the phone to get verification codes every time you submit/publish an iOS app.
This situation can be avoided by adding the reseller's phone number as a trusted phone number in the client's account.
Note: For more details on how trusted phone number verification works, please see Apple's Manage Your Account article.
Prerequisites
- Apple ID Account
Solution
To add a trusted phone number, please follow the steps below. Note that just for the first time you will need to be on the phone with your client.
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Ask your client to log in to their Apple ID account page and have them:
a. Go to Security > Edit > Add a Trusted Phone Number.
b. Enter your phone number, select a verification method, then click Send.
2. Give them the code you will have received and have them enter the six-digit verification code to verify it.
Testing
Your phone number will have been added to your client's Apple ID account as a trusted number and from now on you will be able to receive 2FA codes on your phone.
Comments
1 comment
As a side note to help resellers: Apple has implemented a limit on how many times your specific phone number can be added as a trusted phone number. I don't know what that limit is, but I can no longer use my cell phone number as a trusted phone number for my clients. I was able to temporarily get around this issue by creating a Google Voice number, and using that number as the trusted phone number moving forward. This is only a temporary solution, because you're only allowed one Google Voice number, and eventually you will get restricted on your Google Voice number as well.
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