Overview
You noticed that your iOS publishing status has been 'Update in Progress' for a period of time that is over the 1-2 weeks that is needed for your app to be uploaded on the Apple Store. This article explains why this may occur and how it can be fixed by accepting the Apple License Agreement.
Diagnosis
On the CMS side, if you try to publish your app again you will get a message "Update in progress".
Also, on the Apple Developer Console you will see the following notice:
The Apple Developer Program License Agreement has been updated.
In order to access certain membership resources, you must accept the latest license agreement
Moreover, if the BiznessApps iOS Uploads Team tries to upload the app on the Apple Store, they will receive an error message:
You currently don't have access to this membership resource. To resolve this issue your team's Account Holder, <name>, must agree to the latest Program License Agreement.
The error mentioned above occurs as there is a pending License Agreement in the Apple Developer console under Account Information that has yet to be accepted.
Solution
Since this is due to Apple's update on the license agreement, the developer needs to accept the agreement from their account to resolve the issue.
- Log in to the Apple Developer account.
- If not directed to the Overview page, click on the alert at the top of your screen
- Review and then Accept the License Agreement.
Testing
The "You currently don't have access to this membership resource" error message will disappear and the BiznessApps Uploads Team will be able to upload your iOS app on the Apple Store.
Note: If by the time you fix the problem, the invitation to the BiznessApps iOS Uploads Team for uploading the app on the Apple Store is expired, you may be asked to send a new one.
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