Overview
If you face issues with your Web Applications (PWA), then you should follow the troubleshooting steps below to try to fix your PWA problems.
Diagnosis
You have problems with your PWA and you don't know how to go about troubleshooting it. These problems may vary from visualization issues (eg design does not appear as expected) to specific functionality not working (eg google maps) or even specific features not working (reservation or website feature)
Solution
a. First, check if you face any of the problems below. Should that be the case, have a read at the corresponding KB article:
- Reservation Feature Does Not Appear On A PWA (Progressive Web App)
- QR Code not working for Web app (PWA)
- PWA Shows URL On IOS
- PWA Content Is Not Updated On The Browser
- Google Maps Not Working On PWA
- PWA Design Looks Different On Desktop Than On Previewer
- PWA Carousel Image Flickering Transition On IOS
b. If the above KBs cannot help you work around your issue you can try the following steps to try to locate the root cause of your problem.
Case 1: Check if the specific feature is supported on PWA
- The feature you are looking for may not be supported on PWA. Follow this article to see the list of supported features on PWA: Feature List for iOS, Android and PWA
Case 2: Check if the problem persists after you clear your browser's cache:
- Have you cleared your browser's cache?
Sometimes, the issue may be browser-related, and it is necessary to clear the browser's cache.
Case 3: Find the device this is happening
- Is the issue happening on an Android device, an iOS device, or a PC?
Test on various devices to identify the scope of the issue.
Case 4: Find the browser this is happening
- Which internet browser is impacted?
Since PWAs are loaded on browsers, it is crucial to collect information about the browser in question. This helps in narrowing down the problem if it is common across different browsers or on a particular browser. Just remember that PWA works directly with a browser, so the device can be virtually anything that a browser is compatible with.
Case 5: Check the URL
- Are the PWA URLs inaccessible?
- Use a DNS Checker to confirm the availability of the CNAME, i.e., the PWA URL.
- A DNS lookup service is for checking the domain name server records against a randomly selected list of DNS servers from different corners of the world.
- Advise the customer to reach out to their CNAME hosting provider to verify the configs and DNS resolution for the subdomain linking.
Testing
After taking the above steps, you should be able to pinpoint the root cause of your PWA issue.
If you are still having trouble, then please provide the following info (by creating a new ticket or appending it to your existing ticket), so that agents can troubleshoot the problem and escalate to Engineering where needed.
Info needed on a ticket:
1. What is the platform/device where PWA faces the issue? (Android, iOS)
2. What is the device brand and model where PWA faces the issue? (e.g., Samsung Galaxy S10 or iPhone 8 Plus)?
Note: Older (i.e., out of support) devices like iPhone 5 are not supported.
3. What version of the OS is running on the device (e.g., Android 9.0 Pie or iOS 12)?
4. Which browser/version are you using (Eg Google Chrome v80)?
5. What is actually the problem you are facing? Please provide as many details as possible?
6. How can this problem be reproduced?
Related Articles
- Introduction to Progressive Web App (PWA)
- How Progressive Web App (PWA) works.
- Reservation Feature Does Not Appear On A PWA (Progressive Web App)
- QR Code not working for PWA
- PWA Shows URL On IOS
- PWA Content Is Not Updated On The Browser
- Google Maps Not Working On PWA
- PWA Design Looks Different On Desktop Than On Previewer
- PWA Carousel Image Flickering Transition On IOS
Comments
0 comments
Please sign in to leave a comment.